Welcome, Guest
Username: Password: Remember me
Welcome to the eaDocX forum!

The place to search for answers or pose new questions about how eaDocX works.
  • Page:
  • 1

TOPIC: eaDocX 3.9 installation error 80040154 with EA 15

eaDocX 3.9 installation error 80040154 with EA 15 2 months 3 weeks ago #3838

Hello,

A client is using eaDocX 3.9.5.7 and recently upgraded to EA15.1 (build 1529).
eaDocX is installed without admin right (in appdata, just for the user) on the Windows 10 PC.

In EA 15, eaDocX is not available and appears with error "Missing (0x80040154)" in the Manage Addins window. I did a test on my PC and I get the same issue. I also tried to install eaDocX 3.9 with the admin rights -> same error

There's no issue with v4.3 in EA15.1 but that's not the version they're using.

Using Adrian's EA Inspector, I can see that eaDocX 4 is built with .Net 4.0, whereas eaDocX 3.9 is built with .Net 2.0

Is there a workaround to fix this?

Note: there's no plan to move to v4
Last Edit: 2 months 3 weeks ago by Guillaume_Viseo.
The administrator has disabled public write access.

eaDocX 3.9 installation error 80040154 with EA 15 2 months 3 weeks ago #3839

  • eaDocX Support
  • eaDocX Support's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1241
  • Thank you received: 139
Sorry - I have no plans to make V4 or V5 available with old version of .net.
According to Microsoft, .net V2 was shpped with Windows XP, and support ended in 2012.
.net 4 arrived in 2016, which is still 4 years ago.

None of which helps you. So you are stuck on the old releases of eaDocX.
Latest releases of eaSDocX and Model Expert (V5 and V2.1) use .net 4.5.1
The administrator has disabled public write access.

eaDocX 3.9 installation error 80040154 with EA 15 2 months 3 weeks ago #3840

I'm ok to keep a .NET 2 built version if there's a way to get it to work. I noticed on a Windows 10 PC that the error comes up when using EA14 or greater (it works ok with EA13.5)

I'm trying to figure out a workaround..
The administrator has disabled public write access.

eaDocX 3.9 installation error 80040154 with EA 15 2 months 3 weeks ago #3841

Just in case it would work, and based on feedback from Sparx users, can you try to build eaDocX 3.9 with .NET 4?
Perhaps it could work without altering the code and that would make this version EA14+ compatible.

Thanks
Last Edit: 2 months 3 weeks ago by Guillaume_Viseo.
The administrator has disabled public write access.

eaDocX 3.9 installation error 80040154 with EA 15 2 months 3 weeks ago #3842

  • eaDocX Support
  • eaDocX Support's Avatar
  • OFFLINE
  • Administrator
  • Posts: 1241
  • Thank you received: 139
[thanks for keeping my name out of the Sparx forum thread :-) ]

Why can't your client upgrade their eadocX version? This is why we have new releases, so we can keep up with changes to OS and Office.
Also, assuming I could re-build with a newer .NET version, how would they download it?
They can only do that if their licences are in support, in which case, why not download the latest eaDocX version, which has all kinds of other fixes as well ?
The administrator has disabled public write access.
  • Page:
  • 1
Moderators: Forum posts
Time to create page: 0.136 seconds